package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[-+]?[0-9]+([\,|\.][0-9]+)?$`)
var str = `1.0
1,0
100000,10000
+10.0
10
1
-10.0`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}