#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(<.+?)\s+style\s*=\s*(["']).*?\2(.*?>)"
Local $sString = "<P style="MARGIN: 0in 0in 10pt" class=MsoNormal><o:p></o:p>&nbsp;</p>"
Local $sSubst = "\1\3"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)