import re
regex = re.compile(r"(<.+?)\s+style\s*=\s*([\"']).*?\2(.*?>)")
test_str = "<P style="MARGIN: 0in 0in 10pt" class=MsoNormal><o:p></o:p>&nbsp;</p>"
subst = "\\1\\3"
result = regex.sub(subst, test_str)
if result:
print(result)