re = /(<.+?)\s+style\s*=\s*(["']).*?\2(.*?>)/
str = '<P style="MARGIN: 0in 0in 10pt" class=MsoNormal><o:p></o:p>&nbsp;</p>'
subst = '\\1\\3'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result