$re = '/(<.+?)\s+style\s*=\s*(["\']).*?\2(.*?>)/';
$str = '<P style="MARGIN: 0in 0in 10pt" class=MsoNormal><o:p></o:p>&nbsp;</p>';
$subst = "\1\3";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;