package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^ftp://.*\.mp3$`)
var str = `May 23 17:26:43 dnsonly webmin[2317]: Invalid login as root from 199.168.254.10`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}