$re = '/^ftp://.*\.mp3$/';
$str = 'May 23 17:26:43 dnsonly webmin[2317]: Invalid login as root from 199.168.254.10';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);