import Foundation
let pattern = #"^ftp://.*\.mp3$"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"May 23 17:26:43 dnsonly webmin[2317]: Invalid login as root from 199.168.254.10"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}