#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?ims)((?:(?:PUBLIC|PRIVATE)[ \t]+)*(?:(?:DEFAULT)[ \t]+)*FUNCTION[ \t]+(?:(\w+)(?:[ \t]*\(([^\(\)]*)\))*))(?:.*)END FUNCTION"
Local $sString = " public default Function abc (a, b, c)" & @CRLF & _
"ksdjflkj lkjlk jd()" & @CRLF & _
"lkjdlkfj" & @CRLF & _
"lkdjf (sdfd())" & @CRLF & _
"kljlkj sd" & @CRLF & _
"fd fdsflkdsjjdsk lkjsdlkj" & @CRLF & _
"end Function"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")