import re
regex = re.compile(r"((?:(?:PUBLIC|PRIVATE)[ \t]+)*(?:(?:DEFAULT)[ \t]+)*FUNCTION[ \t]+(?:(\w+)(?:[ \t]*\(([^\(\)]*)\))*))(?:.*)END FUNCTION", flags=re.IGNORECASE | re.MULTILINE | re.DOTALL)
test_str = (" public default Function abc (a, b, c)\n"
"ksdjflkj lkjlk jd()\n"
"lkjdlkfj\n"
"lkdjf (sdfd())\n"
"kljlkj sd\n"
"fd fdsflkdsjjdsk lkjsdlkj\n"
"end Function")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")