import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "((?:(?:PUBLIC|PRIVATE)[ \\t]+)*(?:(?:DEFAULT)[ \\t]+)*FUNCTION[ \\t]+(?:(\\w+)(?:[ \\t]*\\(([^\\(\\)]*)\\))*))(?:.*)END FUNCTION";
final String string = " public default Function abc (a, b, c)\n"
+ "ksdjflkj lkjlk jd()\n"
+ "lkjdlkfj\n"
+ "lkdjf (sdfd())\n"
+ "kljlkj sd\n"
+ "fd fdsflkdsjjdsk lkjsdlkj\n"
+ "end Function";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE | Pattern.MULTILINE | Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}