#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "\[youtube\].*(?:(?:youtu\.be\/|v\/|vi\/|u\/\w\/|embed\/)|(?:(?:watch)?\?v(?:i)?=|\&v(?:i)?=))([^#\&\?]*).*\[\/youtube\]"
Local $sString = "[youtube]https://www.youtube.com/watch?v=ikyBLVda00I[/youtube]" & @CRLF & _
"[youtube]https://www.youtube.com/watch?v=PT2_F-1esPk&list=PLMC9KNkIncKtPzgY-5rmhvj7fax8fdxoj&index=5[/youtube]" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"[youtube]https://youtu.be/kOkQ4T5WO9E?list=PLMC9KNkIncKtPzgY-5rmhvj7fax8fdxoj[/youtube] " & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"[youtube]https://www.youtube.com/watch?v=ikyBLVda00I[/youtube]" & @CRLF & _
"[youtube]https://www.youtube.com/watch?v=PT2_F-1esPk&list=PLMC9KNkIncKtPzgY-5rmhvj7fax8fdxoj&index=5[/youtube]" & @CRLF & _
"" & @CRLF & _
"[youtube]https://www.youtube.com/watch?v=ikyBLVda00I[/youtube]" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")