use strict;
my $str = '[youtube]https://www.youtube.com/watch?v=ikyBLVda00I[/youtube]
[youtube]https://www.youtube.com/watch?v=PT2_F-1esPk&list=PLMC9KNkIncKtPzgY-5rmhvj7fax8fdxoj&index=5[/youtube]
[youtube]https://youtu.be/kOkQ4T5WO9E?list=PLMC9KNkIncKtPzgY-5rmhvj7fax8fdxoj[/youtube]
[youtube]https://www.youtube.com/watch?v=ikyBLVda00I[/youtube]
[youtube]https://www.youtube.com/watch?v=PT2_F-1esPk&list=PLMC9KNkIncKtPzgY-5rmhvj7fax8fdxoj&index=5[/youtube]
[youtube]https://www.youtube.com/watch?v=ikyBLVda00I[/youtube]
';
my $regex = qr/\[youtube\].*(?:(?:youtu\.be\/|v\/|vi\/|u\/\w\/|embed\/)|(?:(?:watch)?\?v(?:i)?=|\&v(?:i)?=))([^#\&\?]*).*\[\/youtube\]/p;
if ( $str =~ /$regex/ ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}