re = /\[youtube\].*(?:(?:youtu\.be\/|v\/|vi\/|u\/\w\/|embed\/)|(?:(?:watch)?\?v(?:i)?=|\&v(?:i)?=))([^#\&\?]*).*\[\/youtube\]/
str = '[youtube]https://www.youtube.com/watch?v=ikyBLVda00I[/youtube]
[youtube]https://www.youtube.com/watch?v=PT2_F-1esPk&list=PLMC9KNkIncKtPzgY-5rmhvj7fax8fdxoj&index=5[/youtube]
[youtube]https://youtu.be/kOkQ4T5WO9E?list=PLMC9KNkIncKtPzgY-5rmhvj7fax8fdxoj[/youtube]
[youtube]https://www.youtube.com/watch?v=ikyBLVda00I[/youtube]
[youtube]https://www.youtube.com/watch?v=PT2_F-1esPk&list=PLMC9KNkIncKtPzgY-5rmhvj7fax8fdxoj&index=5[/youtube]
[youtube]https://www.youtube.com/watch?v=ikyBLVda00I[/youtube]
'
# Print the match result
str.match(re) do |match|
puts match.to_s
end