import Foundation
let pattern = ##"\[youtube\].*(?:(?:youtu\.be\/|v\/|vi\/|u\/\w\/|embed\/)|(?:(?:watch)?\?v(?:i)?=|\&v(?:i)?=))([^#\&\?]*).*\[\/youtube\]"##
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
[youtube]https://www.youtube.com/watch?v=ikyBLVda00I[/youtube]
[youtube]https://www.youtube.com/watch?v=PT2_F-1esPk&list=PLMC9KNkIncKtPzgY-5rmhvj7fax8fdxoj&index=5[/youtube]
[youtube]https://youtu.be/kOkQ4T5WO9E?list=PLMC9KNkIncKtPzgY-5rmhvj7fax8fdxoj[/youtube]
[youtube]https://www.youtube.com/watch?v=ikyBLVda00I[/youtube]
[youtube]https://www.youtube.com/watch?v=PT2_F-1esPk&list=PLMC9KNkIncKtPzgY-5rmhvj7fax8fdxoj&index=5[/youtube]
[youtube]https://www.youtube.com/watch?v=ikyBLVda00I[/youtube]
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}