package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)\w+ id(\d{4})\:\n(.*)\n{3}`)
var str = `nickname id0001:
this is a message
nickname id0002:
this is a message
nickname id0003:
this is
a multiline
message
nickname id0004:
this is a message`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}