re = /\w+ id(\d{4})\:\n(.*)\n{3}/i
str = 'nickname id0001:
this is a message
nickname id0002:
this is a message
nickname id0003:
this is
a multiline
message
nickname id0004:
this is a message'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end