const regex = /\w+ id(\d{4})\:\n(.*)\n{3}/gi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\w+ id(\\d{4})\\:\\n(.*)\\n{3}', 'gi')
const str = `nickname id0001:
this is a message
nickname id0002:
this is a message
nickname id0003:
this is
a multiline
message
nickname id0004:
this is a message`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}