import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\w+ id(\\d{4})\\:\\n(.*)\\n{3}";
final String string = "nickname id0001:\n"
+ "this is a message\n\n\n"
+ "nickname id0002:\n"
+ "this is a message\n\n\n"
+ "nickname id0003:\n"
+ "this is\n"
+ "a multiline\n"
+ "message\n\n\n"
+ "nickname id0004:\n"
+ "this is a message";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}