#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "\d{3,}(?=_)"
Local $sString = "70707_70708_70709_display1.jpg" & @CRLF & _
"70707_Front010.jpg" & @CRLF & _
"626-this files is tagged.jpg" & @CRLF & _
"1000x1000_webbanner2.jpg" & @CRLF & _
"2000 years ago_files.jpg" & @CRLF & _
"626gamingassets_styleguide.jpg"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")