import re
regex = re.compile(r"\d{3,}(?=_)")
test_str = ("70707_70708_70709_display1.jpg\n"
"70707_Front010.jpg\n"
"626-this files is tagged.jpg\n"
"1000x1000_webbanner2.jpg\n"
"2000 years ago_files.jpg\n"
"626gamingassets_styleguide.jpg")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")