import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\d{3,}(?=_)";
final String string = "70707_70708_70709_display1.jpg\n"
+ "70707_Front010.jpg\n"
+ "626-this files is tagged.jpg\n"
+ "1000x1000_webbanner2.jpg\n"
+ "2000 years ago_files.jpg\n"
+ "626gamingassets_styleguide.jpg";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}