$re = '/\d{3,}(?=_)/';
$str = '70707_70708_70709_display1.jpg
70707_Front010.jpg
626-this files is tagged.jpg
1000x1000_webbanner2.jpg
2000 years ago_files.jpg
626gamingassets_styleguide.jpg';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);