#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mi)(?!\bsleep\b)(?=.*)\b(1[012]|[0-9]) {0,1}[ap]m{0,1}\b"
Local $sString = "onset: 내원 당일 3pm" & @CRLF & _
"sleep : 평소 1am~12pm / 당일에도 평소만큼 잠" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")