const regex = new RegExp('(?!\\bsleep\\b)(?=.*)\\b(1[012]|[0-9]) {0,1}[ap]m{0,1}\\b', 'gmi')
const str = `onset: 내원 당일 3pm
sleep : 평소 1am~12pm / 당일에도 평소만큼 잠
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}