using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?!\bsleep\b)(?=.*)\b(1[012]|[0-9]) {0,1}[ap]m{0,1}\b";
string input = @"onset: 내원 당일 3pm
sleep : 평소 1am~12pm / 당일에도 평소만큼 잠
";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}