$re = '/(?!\bsleep\b)(?=.*)\b(1[012]|[0-9]) {0,1}[ap]m{0,1}\b/mi';
$str = 'onset: 내원 당일 3pm
sleep : 평소 1am~12pm / 당일에도 평소만큼 잠
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);