package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(pt_.+_kor)`)
var str = `05/15/2015 09:19 PM pt_Product2017.9.abc.swl.px64_kor_7700`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}