$re = '/(pt_.+_kor)/';
$str = '05/15/2015 09:19 PM pt_Product2017.9.abc.swl.px64_kor_7700';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);