import Foundation
let pattern = #"(pt_.+_kor)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"05/15/2015 09:19 PM pt_Product2017.9.abc.swl.px64_kor_7700"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}