const regex = /(pt_.+_kor)/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(pt_.+_kor)', '')
const str = `05/15/2015 09:19 PM pt_Product2017.9.abc.swl.px64_kor_7700`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}