#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)__[A-Z0-9_]+__(\((?:[^()]++|(?-1))*\))"
Local $sString = "5 + __FXN1__('hello', 1, 3, '__HELLO__(\'hello\') + 5') + 5 + (2/2) + __FXN2__('Good boy') + __FXN2__('Good ((boy')"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")