re = /__[A-Z0-9_]+__(\((?:[^()]++|(?-1))*\))/m
str = '5 + __FXN1__(\'hello\', 1, 3, \'__HELLO__(\\\'hello\\\') + 5\') + 5 + (2/2) + __FXN2__(\'Good boy\') + __FXN2__(\'Good ((boy\')'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end