package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)__[A-Z0-9_]+__(\((?:[^()]++|(?-1))*\))`)
var str = `5 + __FXN1__('hello', 1, 3, '__HELLO__(\'hello\') + 5') + 5 + (2/2) + __FXN2__('Good boy') + __FXN2__('Good ((boy')`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}