const regex = /__[A-Z0-9_]+__(\((?:[^()]++|(?-1))*\))/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('__[A-Z0-9_]+__(\\((?:[^()]++|(?-1))*\\))', 'gm')
const str = `5 + __FXN1__('hello', 1, 3, '__HELLO__(\\'hello\\') + 5') + 5 + (2/2) + __FXN2__('Good boy') + __FXN2__('Good ((boy')`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}