using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\d+\.\d+(?:\.\d+)?";
string input = @"12.2.17
3.04.2018
I further want it to capture the following by making the last part optional:
12.2
13.03";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}