$re = '/\d+\.\d+(?:\.\d+)?/';
$str = '12.2.17
3.04.2018
I further want it to capture the following by making the last part optional:
12.2
13.03';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);