re = /\d+\.\d+(?:\.\d+)?/
str = '12.2.17
3.04.2018
I further want it to capture the following by making the last part optional:
12.2
13.03'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end