import re
regex = re.compile(r"\d+\.\d+(?:\.\d+)?")
test_str = ("12.2.17\n"
"3.04.2018\n\n"
"I further want it to capture the following by making the last part optional:\n\n"
"12.2\n"
"13.03")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")