package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\b(?:[\w'-]{1,3}\W+[\w'-]{4,}|[\w'-]{4,}\W+[\w'-]{1,3}|[\w'-]{4,})\b`)
var str = `An elephant in the garden
history of elephants
Algebra A B-movies
Have you visted Calculus A?
I was in Calculus b
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}