import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\b(?:[\\w'-]{1,3}\\W+[\\w'-]{4,}|[\\w'-]{4,}\\W+[\\w'-]{1,3}|[\\w'-]{4,})\\b";
final String string = "An elephant in the garden \n"
+ "history of elephants\n"
+ "Algebra A B-movies\n\n"
+ "Have you visted Calculus A?\n"
+ "I was in Calculus b\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}