$re = '/\b(?:[\w\'-]{1,3}\W+[\w\'-]{4,}|[\w\'-]{4,}\W+[\w\'-]{1,3}|[\w\'-]{4,})\b/';
$str = 'An elephant in the garden
history of elephants
Algebra A B-movies
Have you visted Calculus A?
I was in Calculus b
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);