import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "([A-Z]{4})";
final String string = "Some random stock symbol: MSFT AAPL INTC";
final String subst = "<a href=\"https://finance.yahoo.com/q?s=\\1\">\\1</a>";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}