import re
regex = re.compile(r"([A-Z]{4})")
test_str = "Some random stock symbol: MSFT AAPL INTC"
subst = "<a href=\"https://finance.yahoo.com/q?s=\\1\">\\1</a>"
result = regex.sub(subst, test_str)
if result:
print(result)