import Foundation
let pattern = #"([A-Z]{4})"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"Some random stock symbol: MSFT AAPL INTC"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"<a href="https://finance.yahoo.com/q?s=\1">\1</a>"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)