$re = '/([A-Z]{4})/';
$str = 'Some random stock symbol: MSFT AAPL INTC';
$subst = "<a href=\"https://finance.yahoo.com/q?s=\1\">\1</a>";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;