import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<(?:button|input|a)\\s+[^>]*class\\s*=\\s*[\"'][^\"']*btn[^\"']*[^>]*>";
final String string = "<button type=\"submit\" class=\"btn btn-default btn-block\">\n"
+ "<input type=\"button\" class=\"btn btn-default multilingual-helper\" value=\"{{ language.code.upper() }}\"/>";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}