re = /<(?:button|input|a)\s+[^>]*class\s*=\s*["'][^"']*btn[^"']*[^>]*>/mi
str = '<button type="submit" class="btn btn-default btn-block">
<input type="button" class="btn btn-default multilingual-helper" value="{{ language.code.upper() }}"/>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end