using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\b(?:Saldo|Total)\s(?!0[.,]00\b)\d{1,3}(?:,\d{3})*\.\d\d\b";
string input = @"1.214,41
4,431.43
143,134.43
355.352,41
443,113,134.43
365.115.352,41
Total 341,431.43
Saldo 0.00
Saldo 0,00
Total 1,431.43
Total 0,00
Saldo 0.60";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}