const regex = /\b(?:Saldo|Total)\s(?!0[.,]00\b)\d{1,3}(?:,\d{3})*\.\d\d\b/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\b(?:Saldo|Total)\\s(?!0[.,]00\\b)\\d{1,3}(?:,\\d{3})*\\.\\d\\d\\b', 'gm')
const str = `1.214,41
4,431.43
143,134.43
355.352,41
443,113,134.43
365.115.352,41
Total 341,431.43
Saldo 0.00
Saldo 0,00
Total 1,431.43
Total 0,00
Saldo 0.60`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}